no need of sun to light the way…

Never touch a running system

Alte Informatikerbinsenweisheit. Natürlich sind Informatiker ja quasi ununterbrochen dabei, irgendwelche laufenden Systeme anzupassen. Es sei denn natürlich, sie entwerfen gerade Systeme von Grund auf neu. Aber selbst dann: Einmal in Betrieb genommen, ist Wartung und somit weitere Anpassung notwendig. Und was die Wartung angeht, ist irgendwann mal der Punkt erreicht, an dem man einfach mal die Schnauze voll hat und dann doch wieder alles umkrempelt. 😉

So kürzlich geschehen mit dem Netzwerk bei meinen Eltern. Da werkelte seit 2003 ein Windows-Server-System lustig vor sich hin. Und fraß eine gehörige Menge Strom. Und nervte allmählich mit zunehmenden Systemabstürzen – vermutlich war die schon damals nicht ganz taufrische Hardware einfach in die Jahre gekommen. Außerdem trieb mich die unzuverlässige Backup-Software bald an den Rand des Wahnsinns, weil die sich alle Nase lang verschluckte und ein fummeliges Neuanlegen des Backup-Jobs nötig machte.

Klein Karlchen stellte also diverse Überlegungen an: Schnellere und zuverlässigere Hardware muss her. Sie sollte aber genügsam im Stromverbrauch sein. Zudem sollte das Backup der Homelaufwerke zuverlässig funktionieren. Da ich jetzt ja doch schon bald 3 1/2 Jahre überwiegend einen Mac nutze, gingen weitere Überlegungen in die Richtung, das W2k3-System gegen einen Mac mini mit OSX Lion Server auszutauschen. Das Kistchen frisst im Leerlauf ja nur um die 10 Watt – müsste also ganze 10 Stunden laufen, um genauso viel Strom verbraucht zu haben, wie der alte Server in nur einer einzigen Stunde. Tjaha, das Argument zog bei meinen Eltern. Zudem war auch eine komplette Domäne inklusive servergespeicherter Benutzerprofile im Gegensatz zu damals nicht mehr nötig, so dass Lion (das im Gegensatz zu Snow Leopard Server ja nicht mehr als Domaincontroller fungieren kann) auch ausreichen sollte.

Erster Start der Server-App

Erster Start der Server-App

Nach einigem Hin-und-Her war es dann vorletztes Wochenende soweit: Ich konnte die Umstellung in Angriff nehmen. Frohen Mutes ging ich ans Werk; grundlegende Einstellungen waren – obwohl ich, getreu besagter Binsenweisheit, mein MacBook immer noch nicht von Snow Leopard auf Lion upgegradet habe – wie von Mac OS gewohnt, ratzfatz erledigt. Etwaiges Gejammer über irgendwelche Seltsamkeiten von Lion konnte ich so weit mal nicht nachvollziehen. Dann blieb ja nur noch, mal eben schnell (Harhar!) die Server-App zu kaufen und einzurichten. Wenn das auch so Apple-typisch butterweich über die Bühne ginge, wäre das Einrichten des neuen Servers an einem Abend geschafft – so dachte ich zumindest, ich Naivchen.

Nachdem die Server-App schon beim ersten Start und der grundlegenden Konfiguration der Dienste erst mal einen Fehlerbericht gen Cupertino schicken wollte, bekam meine Euphorie schon einen ersten Dämpfer. Aber nun gut, nobody’s perfect, und solange so ein Absturz nicht im laufenden Betrieb geschieht, ist ja so weit noch alles in Butter.

Hilfreiche Hilfe ist hilfreich

Aber weiter im Text: Die App startete dann doch irgendwann und präsentierte mir eine Liste zu konfigurierender Dienste, wie bleistiftsweise Dateiserver, Mailserver, Webserver… Allein: Die grundlegenden Dinge, die ich zuallererst mal einstellen wollte, blieben mir verwehrt. Keine Konfiguration für DHCP und DNS und dergleichen. Die Hilfe gab sich ungewohnt microsoftsch und verriet mir, dass ich doch bitte darauf achten solle, dass der Server im DNS korrekt eingetragen ist. Im Übrigen sogar mit einem Link zum Thema DNS-Server – der dann auch eher microsofttypisch ins Leere führte. Ein wenig Resignation machte sich breit.

Verzagen stand allerdings definitiv nicht auf dem Programm, also was tun? Das Internet™ befragen! Und siehe da: Für diese Zwecke gibt es die Server-Admin-App, die separat von den Apple-Support-Seiten heruntergeladen werden muss. Ja nee, is’ klar. An dieser Stelle blickte ich mich verstohlen nach der verstecken Kamera um. Das war jetzt nicht wirklich Apples Ernst, oder? Immerhin: Nach der Installation der Server-Admin-App ging dann die weitere Einrichtung recht reibungslos von statten, wenn man mal über diverse weitere Seltsamkeiten auf Apples Supportseiten hinwegsieht.

Unbeschreibliche Fehlermeldung ist unbeschreiblich

Unbeschreibliche Fehlermeldung ist unbeschreiblich

Den nächsten Brüller lieferte sich dann in der Tat – und wie eigentlich von vornherein erwartet – Microsoft. Damit die Familie die noch im Netz vorhandenen Windows-Rechner weiterhin wie gewohnt nutzen konnte, mussten natürlich die bis dato als Domainuser angelegten Benutzerkonten jeweils am gewünschten PC lokal angelegt werden. Dazu galt es natürlich, die lokalen Admin-User zu reaktivieren… Der Screenshot spricht mal wieder Bände – ebenso die Kuhle im Schreibtisch an der Stelle, an der mein Kopf diverse Male auftraf.

Nachdem diese Hürde genommen war, rechnete ich mit weiterem Ärger beim Klonen der Benutzereinstellungen. Zwar bietet Windows hierzu eine wenn auch reichlich versteckte aber trotzdem simple Funktion: Altes Benutzerprofil auswählen, „Kopieren nach…“ anklicken, Zielverzeichnis und neuen Usernamen angeben und warten. Der Kopiervorgang geht dann völlig ohne Fortschrittsbalken von statten. Der einzige Indikator, dass es geklappt hat, ist das Verschwinden des Dialogfensters. Bleibt es dagegen stehen während im Gegenzug der Mauscursor aber wieder zum gewohnten Pfeil wird, ist es schiefgegangen. Eindeutiges Benutzerfeedback for the win!

Klappte diese Übung am PC meiner Mutter noch reibungslos, so machte mir am Laptop meines Vaters der Standby-Modus erst mal einen Strich durch die Rechnung. *hüst* Nun ja. Man kann ja auch nicht an alles denken. Also zweiter Versuch mit abgeschalteten Energiesparoptionen. Aber da spielte Windows nun nicht mehr mit: Ohne einen Neustart ließ sich das Profil nicht kopieren. Aber immerhin klappte es dann. Die härteste Nuss war dann der PC meines Bruders. Diverse Versuche, sein Userprofil zu klonen, schlugen allesamt fehl. Nun half Windows ja auch tatkräftig mit, dass ich mir noch mehr meiner eh nur noch sparsam vorhandenen Haare raufen durfte. Wie gesagt: Keine Fehlermeldung, kein gar nix.

Schlussendlich half dann der Versuch, einfach mal manuell sämtliche Verzeichnisse umzuziehen. Hier motzte dann der Windows-Explorer beim Versuch, Dateien des SecuROM-Kopierschutzes zu kopieren. Und siehe da: Kaum war der entfernt, klappte auch das ordnungsgemäße Kopieren des Benutzerprofils über die von Microsoft vorgesehene Weise. Die Windows-Domäne konnte also endgültig aufgelöst werden. Kinners, was ein Akt.

Advertisements

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s